Blogブログ

【letsencrypt更新】TLS-SNI-01認証で作成・更新された証明書に重大な脆弱性

2019/01/28

letsencryptよりメールで下記のようなメッセージが来ていた
2019年2月13日移行廃止予定とのこと
メール内の公式情報をみると
https://community.letsencrypt.org/t/how-to-stop-using-tls-sni-01-with-certbot/83210
Certbotのバージョンが0.28以上
だとか。
早速更新しましょ

1.バージョン確認
#certbot --version
certbot 0.27.1

 

2.certbot更新
#yum update certbot

Dependency Updated:
python2-certbot.noarch 0:0.29.1-1.el7
Complete!

 

3.dry-runで更新テスト
エラー:acmeバージョン0.29.0以上が見つからん
#certbot renew --dry-run --preferred-challenges http
pkg_resources.DistributionNotFound: acme>=0.29.0

 

4.acmeを更新
#yum --enablerepo=epel update python2-acme

 

5.再度dry-runで更新テストでクリア

 

以下メール内容

Hello,

Action may be required to prevent your Let’s Encrypt certificate renewals
from breaking.

If you already received a similar e-mail, this one contains updated
information.

Your Let’s Encrypt client used ACME TLS-SNI-01 domain validation to issue
a certificate in the past 60 days. Below is a list of names and IP
addresses validated (max of one per account):

xxxx.com (IPアドレス) on 日付

TLS-SNI-01 validation is reaching end-of-life. It will stop working
temporarily on February 13th, 2019, and permanently on March 13th, 2019.
Any certificates issued before then will continue to work for 90 days
after their issuance date.

他社より断然お得で使いやすい
”アクトのWEB制作”
ACTホームページ相談窓口 / 
システム開発相談窓口